lunes, mayo 07, 2007

Cuestionario OpenSuse

Hola holita,

hace mucho que no discutimos, ¿no?. Venga, un poco de guerra. ;)

Durante tres meses Novell ha realizado un cuestionario sobre Linux y OpenSuse a más de 27.000 personas. Algunos de los resultados curiosos:

1.- Solo el 2 % eran mujeres.

[maligno mode]
Yo creo que esto va a ser razón más que suficiente para pensarse dos veces el tema de elegir la comunidad adecuada. En otro orden de cosas había que pensarse como sólo un 2% son mujeres en ese target. ¿No estaremos teniendo un Linux machista?
[/maligno mode]


2.- De la propiedades de Precio, Cantidad y selección de Software, Documentación, Servicios de Soporte, facilidad de servicio, facilidad de Instalación, Usabilidad, Estabilidad, Seguridad, soporte de Hardware y soporte Multimedia lo que peor han valorado han sido el soporte multimedia y los servicios de soporte.

[maligno mode]
Pues si los servicios de soporte de OpenSuse son de lo que peor valoran….
[/maligno mode]


3.-¿Qué entorno gráfico usas?

KDE el 71.8 % versus Gnome 22,4 %, xfce 1,2 %, consola 1,9 % y “otros” 2.7 %


[maligno mode]
Mu bonitos los interfaces en 3D y esas cositas pero justo lo que necesito para administrar las Asociaciones de Seguridad en IPSec es que la ventana vibre como un flan.
[/maligno mode]


4.- ¿Tienes arranque dual con Windows?

Sí 69,5


[maligno mode]
No comment.
[/maligno mode]


5.- ¿Cuál es tu profesión?


[maligno mode]
¿Necesitas que haga algún comentario de esto?
[/maligno mode]


Descargate el informe completo de la siguiente URL:

Informe Cuestionario OpenSuse

12 comentarios:

Gangrolf dijo...

juas, pues mira, hablando de cosas libres, aprovecho para poner esto:

Múltiples vulnerabilidades en PHP 4.4.x y 5.2.x
-----------------------------------------------

Se han descubierto múltiples vulnerabilidades en PHP de las cuales
algunas tienen un impacto desconocido y otras podrían ser aprovechadas
por un atacante para obtener acceso a información importante, manipular
datos, eludir restricciones de seguridad o causar denegaciones de
servicios.

* Un error no especificado en ftp_putcmd podría ser aprovechado por un
atacante para inyectar caracteres newline.

* Un error no especificado en import_request_variables podría ser
aprovechado por un atacante para sobrescribir variables globales.

* Un error no especificado podría ser aprovechado para causar un
desbordamiento de buffer en la función make_http_soap_request.

* Un error no especificado podría ser aprovechado para causar un
desbordamiento de búfer en la función user_filter_factory_create.

* Un error no especificado en la librería libxmlrpc podría ser
aprovechado por un atacante remoto para causar un desbordamiento de
búfer.

* Un error de la validación de la entrada de datos en la función mail
permitiría a un atacante inyectar cabeceras a través de los parámetros
To y Subject.

* Un error en la función mail permitiría a un atacante truncar mensajes
a través de bytes ASCIIZ

* Los mecanismos de protección safe_mode y open_basedir podrían ser
eludidos por un atacante a través de los wrappers zip:// y bzip://

* Un desbordamiento de entero en substr_compare podría ser aprovechado
por un atacante para leer la memoria más allá de la zona de memoria
donde están localizadas las variables de PHP. Esto también afecta a la
función substr_count.

* Un error en mb_parse_str podría ser aprovechado por un atacante para
activar register_globals.

* Un error en el motor Zend referido a los arrays anidados de variables
podría ser aprovechado por un atacante para hacer que una aplicación
dejase de funcionar.

Se recomienda actualizar a la versión 5.2.2 o 4.4.7 desde
http://www.php.net.

Se recomienda otorgar permisos de ejecución de código PHP sólo a
usuarios de confianza.

Opina sobre esta noticia:
http://www.hispasec.com/unaaldia/3116/comentar

Más información:

PHP 5.2.2 Release Announcement
http://www.php.net/releases/5_2_2.php

PHP 4.4.7 Release Announcement
http://www.php.net/releases/4_4_7.php

Gangrolf dijo...

(añadido al anterior)

Es que cuando te llegan 11 vulnerabilidades de golpe es para echarse a temblar no?
Particularmente me gusta este comentario:

"Se recomienda otorgar permisos de ejecución de código PHP sólo a
usuarios de confianza."


Que políticamente correctos, yo hubiera puesto se recomienda no usar php en pàginas serias.

Troxer dijo...

Maligno si lo que quieres es guerra pásate por este hilo de mi blog, que tengo allí a un par de linuxeros tirando dentelladas y a FileMaster (que si le vieran en persona, le tendrían más respeto) dando cera.

Y luego se molestan cuando les llamas talibanes...

Gura dijo...

Yo me pregunto: ¿Qué hace un servicio de hosting como Arsys o similar si se ve afectado por una vulnerabilidad de esta embergadura? Cruzar los dedos?

txipi dijo...

@Maligno: OpenSUSE es una distro muy "My pequeño pony" es normal que la gente use KDE, necesite soporte Multimedia y sean todos estudiantes. Solamente la están instalando para vacilar con Beryl y tratar de hacerse a la jefa de las animadoras (por eso tampoco hay mucha chica usándolo). Una encuesta parecida en Slackware, Gentoo o Debian hubiera sido "diferente" :-D

@gangrolf: cada mes me llega un Una al día que dice: Microsoft parchea N vulnerabilidades. Y normalmente N suele ser mayor que 11. En todos los sitios cuecen habas ;-P

Maligno dijo...

Troxer, eso es un hilo, es una madeja!!

a ver si tengo tiempo de leerme toda la enciclopedia británica que se ha escrito allí. De momento esta Filemaster, así que dejémosle fajarse. ;)

Txipi, Berryl no parece que lo hayan instalado mucho...

Matias dijo...
Este comentario ha sido eliminado por el autor.
Matias dijo...

Mira que eres malo, me dejas solo ante el peligro...

Por cierto muy instructiva la encuesta e interesante...

FilEMASTER

PD:No me apetece cambiar de nick que luego me da por saco la pagina inicial de google

Karhgot dijo...

Gangrolf gracias por la info.
Estoy hasta la polla de actualizar php y cambiar las putas variables x'(
Despues se me quejan de que no funcionan las webs... ains!!!

Gangrolf dijo...

Txipi: Hombre, que quede claro que yo no soy pro-microsoft ni nada. Pero me temo que estas vulnerabilidades, aunque salgan ahora, me temo que llevan mucho latentes y que en particular php es un hervidero de fallos.
Está claro que TODOS los programas tienen algún fallo de seguridad, hasta el notepad tiene bugs. Pero si sumas las vulnerabilidades que se saquen de un linux, digamos M, y las de windows, digamos N y valoramos el porcentaje de cosas parcheadas y cosas pendientes...
Vamos, que no creo que haya mucha gente cuyo trabajo consista en estar esperando fallos de linux para parchearlos rápidamente.
E insisto, no defiendo a Microsoft, podían incluso hacer menos de lo que hacen y se seguiría usando windows (al final todo se reduce a tiempo=dinero!=analisis de fallos), es que el php no me ha gustado nunca, y como parece que es una de las banderas de apache pues...

macmarc dijo...

Una gynkana digital para expertos en seguridad,Este es el titulo de una noticia en el pais,te dejo el enlace Maligno. aquí

Benigno dijo...

Maligno: hablan de entornos de escritorio, no de gestores de ventana, así que malamente puedes saber cuantas personas de esas están usando beryl.

Pal que ha dicho eso de "si lo conocieran en persona..." (creo que hablando de Filemaster): Filemaster puede ser un armario empotrado (2x2...x2), aún así haber tenido tiempo de cultivar el intelecto y ser un ingeniero... de primera y un gran profesional en lo suyo. Pero aún así no creo que sea un dios, y digo "no creo" porque yo en general no creo. Entonces se le pueden rebatir algunas cosillas, como esa varita mágica (que usa más gente) que hace que el nº de profesionales necesarios para manejar un entorno con SL sea (aprox.) chorrocientas veces el de profesionales necesarios para manejar un entorno Windows (y para afirmar eso no son necesarios datos y números de esos que molan al mundillo ingenieril, solo soltarlo y ya), o esa absurda distinción entre software libre y comercial (hala, racismo tecnológico, ahí es ná), etc

Aupa Maligno, que te lo pases bien por las iruñas.

Entrada destacada

Seis recomendaciones personales de libros de @0xWord para disfrutar y aprender

Este verano pude disfrutar de la lectura de un libro que me encantó. El libro de Factfulness que me había regalado mi compañera Beatriz Ce...

Entradas populares